Reply To: CVE-2022-20186

[cvetalks-get-vuln]

#606791
mind_game
Participant

    I attempted to apply CVE-2022-20186 on a Samsung S8+, but encountered an error stating “set flags failed.” The Samsung S8+ is equipped with Mali G71 (r16p0-01), running on kernel version 4.4.111 and Android 9. What could be causing this error, and how can I address this issue?

    exploit code used :https://github.com/github/securitylab/blob/main/SecurityExploits/Android/Mali/CVE_2022_20186/mali_alias.c